Filters
Preferences
Search
0114 3830333
Worldwide shipping & free UK over £35
Close
(0) items
You have no items in your shopping cart.
All Categories
    Manufacturer: The Crafty Kit Company

    Miniature Wirehaired Dachshund Needle Felting Kit

    £18.95
    £22.00
    (approx $24.36 USD or €22.14 Euros)
    If you love Dachshunds you're going to love our Miniature Wirehaired Dachshund Needle Felting Kit!
    Our Code: CKC-NF-122
    Barcode: 5060347381670
    Availability: 13 in stock

    If you love Dachshunds you're going to love our Miniature Wirehaired Dachshund Needle Felting Kit! Our kits come with all the felting wool you need, felting needles, glass eyes, wire, pipe cleaners, a mat to work on and lovely clear step by step instructions. 

    You'll learn how to make a wire armature, then build it up with felting wool, and finally add the details that will really bring your lorikeet to life. 

    This is an 'improvers' kit - so you will already have done a little needle felting before. If you haven't, why not start with one of our brilliant beginners' kits? 

    The finished dog is around 27cm long including the tail.

    This kit is suitable for age 10+. It contains a very sharp needle, so adult supervision is required. 

    Write your own review
    • Bad
    • Excellent

    If you love Dachshunds you're going to love our Miniature Wirehaired Dachshund Needle Felting Kit! Our kits come with all the felting wool you need, felting needles, glass eyes, wire, pipe cleaners, a mat to work on and lovely clear step by step instructions. 

    You'll learn how to make a wire armature, then build it up with felting wool, and finally add the details that will really bring your lorikeet to life. 

    This is an 'improvers' kit - so you will already have done a little needle felting before. If you haven't, why not start with one of our brilliant beginners' kits? 

    The finished dog is around 27cm long including the tail.

    This kit is suitable for age 10+. It contains a very sharp needle, so adult supervision is required.